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Άδειες Χρήσης

• Το παρόν εκπαιδευτικό υλικό υπόκειται σε άδειες 
χρήσης Creative Commons. 

• Για εκπαιδευτικό υλικό, όπως εικόνες, που υπόκειται 
σε άλλου τύπου άδειας χρήσης, η άδεια χρήσης 
αναφέρεται ρητώς. 
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Χρηματοδότηση
• Το παρόν εκπαιδευτικό υλικό έχει αναπτυχθεί στα πλαίσια 

του εκπαιδευτικού έργου του διδάσκοντα.

• Το έργο «Ανοικτά Ακαδημαϊκά Μαθήματα στο Πανεπιστήμιο 
Αιγαίου» έχει χρηματοδοτήσει μόνο τη αναδιαμόρφωση του 
εκπαιδευτικού υλικού. 

• Το έργο υλοποιείται στο πλαίσιο του Επιχειρησιακού 
Προγράμματος «Εκπαίδευση και Δια Βίου Μάθηση» και 
συγχρηματοδοτείται από την Ευρωπαϊκή Ένωση (Ευρωπαϊκό 
Κοινωνικό Ταμείο) και από εθνικούς πόρους.
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Introduction to 3D modeling with Softimage



These are the features that provide your basic interactions:
 Starting and Interacting With Softimage

Covers the methods and startup options available for launching Softimage and the 
interaction model you will use when working in Softimage.

 Interface — Commands and Tools
Introduces all user interface elements and the basic tools for accessing commands and 
modifying parameters and properties.

 Views
Discusses the tools that let you examine your scene in varying degrees of detail. This 
includes the 3D views as well as the general-purpose views such as the Explorer view, 
the Schematic view, and Net View.

 Viewing 3D Objects
Describes the many ways in which you can view scene geometry in the 3D views.

 Rotoscopy
Introduces the rotoscoping technique in which video or film images are placed in the 
background of a 3D view to match your camera’s point of view with that of the images, for 
example.



The first time you open Softimage, you are prompted to choose your preference for interacting with 
Softimage. The interaction model controls how mouse and keystroke interaction will be 
interpreted in Softimage. The interaction model sets the mapping of keyboard shortcuts to 
Softimage commands (key map), whether or not sticky keys are available, which tool is active by 
default, and how key and mouse buttons are used to select objects and components in 3D views.

 Choosing an Interaction Model
 Select an interaction model and click OK. If you want to change your interaction model later, these and 

additional models from the File > Interaction Model menu. For more information, see Changing Interaction 
Preferences.

 Each interaction model simply sets a key map for commands as well as a variety of preferences. You can also 
change key maps and preferences individually to customize your interaction. 

 The documentation assumes that you are using the default SOFTIMAGE interaction model. However, no 
matter which interaction model you choose, the appropriate shortcut keys are displayed in the menus 
dynamically.

 The Recommended Choice
 It is recommended that you choose the SOFTIMAGE interaction model because it is optimized for use with all 

Softimage tools. In particular, it makes the most efficient use of modifier keys like Shift, Ctrl, and Alt. 
 If you prefer to use the Alt key for camera navigation, you can set Use Alt key for view navigation in your 

Tools > Camera preferences (File > Preferences). You can also set Mouse Mapping to Alternate to use the left 
mouse button to orbit, the middle mouse button to pan, and the right mouse button to zoom.





 The main menu bar is the horizontal bar at the top of the Softimage interface. It 
displays menus containing commands for general operations such as managing 
files, editing, setting preferences, opening tools and editors in floating views, 
displaying elements, and accessing the documentation. 



 The Model, Animate, Render, Simulate, and Hair toolbars (see Toolbars) are 
available from the main menu. Each of these toolbars (and each of their menus) 
can be torn off from the main menu bar and kept in a handy floating window for 
the current Softimage session (see Tearing Off Menus). 

 The construction mode selector allows you to select the context (mode) for 
adding operators to the geometry stack for modeling operations, animation, or 
shape animation. See Construction Modes and Regions [Modeling and 
Deformation Basics] for more information.

 The render pass list lets you select the current render pass for the scene. This is 
the same as is available on the Render toolbar, just in an accessible spot when you 
have other toolbars active. See Passes & Partitions for more information.



 The toolbar panel on the left side of the interface 
displays one of five default toolbars at a time: 
Model, Animate, Render, Simulate, and Hair. Each 
of these toolbars contains menus of the commands 
most commonly used for tasks in their area. These 
toolbars are also displayed on the main menu bar.

 To open a menu of commands, click on a menu 
button on the toolbar. Each menu and submenu on 
a toolbar can be torn off and kept in a handy 
floating window for the current Softimage session 
(see Tearing Off Menus). 

 To switch toolbars
 Press 1, 2, 3, 4, or Ctrl+2 on the keyboard, or
 Click the toolbar name at the top and select a toolbar 

from the list. 



 At the bottom of the toolbar panel, there are a number of icons that let you switch between the 
toolbar and other panels, as well as load different interface layouts. 



 The controls in this area give you information, such as what each mouse button 
does or the last command that you used. From here, you can also open the script 
editor for working with scripts. There is also animation information and tools, 
from the timeline and playback controls to the Animation panel.



 The main command panel on the right side of the interface
contains all the commands and tools you will use most
frequently while working in your scene. Commands and tools
that have a similar purpose are grouped into panels.

 You can collapse a panel by right-clicking on its label. Right-
click on the label a second time to expand a collapsed panel.
This can be useful when working at small screen resolutions.

 As well, each menu and submenu on the main command
panel can be torn off and kept in a handy floating window for
the current Softimage session (see Tearing Off Menus).

 See the following sections for information on each group of
commands found in the main command panel.

 Select panel commands and tools—see Selecting [Scene Elements].

 Transform panel commands and tools—see Transformations
[Transformations].

 Snap panel commands and tools—see Snapping [Transformations].

 Constrain panel commands—see Animating with Constraints
[Animation].

 Edit panel commands—see 3D Objects, Components and Clusters,
and Properties [Scene Elements], Models and Displaying Scene
Information [Data Management], and Operator Stack [Modeling
and Deformation Basics].



 You can access most commands from menus on the main menu bar at the top of 
the interface, from the toolbars on the left of the interface or from the main 
menu bar, and from the menus on the main command panel.

 Context Menus
 Some pop-up menus are displayed by Alt+right-clicking or just right-clicking on 

individual elements, such as geometric objects, cameras, and lights, in the 3D 
views, the explorer, and the schematic view, or from specific areas of the 
interface. These type of pop-up menus are called context menus because they 
provide commands that are applicable (in context) to the chosen object.

 In general, when you open a context menu:
 If the element under the mouse pointer is not selected, then only that element is affected by 

the menu command you choose.
 If the element under the mouse pointer is selected, then all selected elements are affected.
 The exception is when you use the context menu in the explorer to mute/unmute

deformations or activate/deactivate constraints. These commands act like toggles, and affect 
only the deformation or constraint under the pointer. A check mark in the menu indicates 
whether the node is currently muted or active. 





 Keyboard shortcuts are specific 
key combinations that perform 
the equivalent of certain menu 
commands. There are two types 
of keyboard shortcuts:
 Access keys —The underlined 

letters you see in many menu 
names. Pressing Alt+[underlined 
letter] activates its associated 
command.

 Shortcut keys —Commands that 
have been mapped to your 
keyboard. For example, pressing 
Ctrl+[key] activates an associated 
command.
▪ The actual shortcut keys (default or 

not) are listed to the right of many 
menu command names. Note that 
not every menu command has a 
shortcut or access key. 



 Shortcut keys are mapped to most of the tools used in Softimage, 
and pressing a key activates a specific tool. Once the key is pressed, 
the mouse pointer changes shape to identify the active tool. Any 
further actions you perform with the mouse are then related to 
that tool. For example, pressing the z key activates the pan and 
zoom tool so that holding down the right mouse button zooms out 
of the scene, and holding down the middle mouse button 
zooms in.

 You can move back and forth between different tools quickly by 
using these shortcut keys. Only one tool can be active at a time.

 Tools can be activated in one of two modes: 
 Sticky—you do not need to hold the key down to activate the tool.
 Supra (temporary)—you must keep the key held down for the tool to 

remain active.



 Property editors are where you’ll find an element’s properties. They are a basic 
tool that you will use constantly to define and modify elements in a scene.



The area in the upper-right corner (below the title bar) contains:
• A Revert icon that lets you reset all controls to the values they had 
when you first opened the property editor.
• A Preset icon allows you to save or load presets of parameter values.
• A Help icon that gives you information on all properties on the 
property set selected on the top tabs. Each property set also has its own 
help icon on its header.



Locking, Recycling, and Focusing Property Editors
The three icons in the upper-right corner control how the property editor 
is updated as you work and select elements.
•The Focus icon updates the current property editor to show the 
properties of the element you select, but only if the element is the same 
type as was previously selected (hence “focusing” on the type of 
element). For example, if you display the property editor of a spotlight 
and then select a point light, that property editor is updated to display 
the properties of the point light because spotlights and point lights are 
both the same type of element. However, if you then select a geometric 
object, a blank page is shown, because lights and geometric objects are 
different types of elements.
•The Recycle icon keeps that property editor open and refreshes it to 
display the properties of any element you select. This is a convenient way 
of keeping only one editor open at all times. For example, if you select a 
cube, the property editor shows the cube’s properties. Then if you select 
a light, the same property editor is updated to show that light’s 
properties.
•The Lock icon keeps the property editor open for the selected element. 
You can open other property editors for other elements, but a locked 
property editor remains open until you close or recycle it.



Animation Controls
The upper-left corner of the property editor, just 
below the title bar, contains the following controls 
related to setting keyframes for properties.
• Two arrow icons that let you move to the previous 
keyframe and next keyframe.
• A keyframe icon that lets you set or remove 
keyframes for the current settings of marked 
parameters on the property page. Right-click for more 
options.



 There is more than one way to access an element’s property 
editor: how you access an editor depends on your current work 
context: 

 Select an object and:
 Press Enter to display a property editor of the object. 
 Press Alt+Enter to display a property editor of the object, as well as 

those that belong to all its children. 

 In the explorer, click the icon of an element or select an element, 
then click the Selection button on the Select panel to display a 
menu from which you can choose certain properties. Click the icon 
of the property set you wish to view.

 Use shortcut keys to open a property editor. Pressing Ctrl+k, for 
example, opens the Local or Global Transform property editor of a 
selected object. You can also create your own shortcut keys to 
open a property editor of your choice.



 Object, shader, or operator parameter values can be edited directly by means of text boxes, check boxes, sliders, 
and virtual sliders located throughout the interface. You will change parameters mostly in property editors (as the 
one shown below). 

 In addition to property editors, you can enter values in many of the text boxes in the main command panel, and 
use virtual sliders to change values in the explorer.

 You change the value of a parameter in a text box by typing in either text or numerical values. If a slider is 
associated with the text box, you can also drag the sliders to raise or lower the numerical values. Some sliders 
and text boxes, such as those that control color channels, are grouped together.

 If the text box contains more characters than it can display, it automatically scrolls with the text cursor.



 Do one of the following:
 Click anywhere along the slider to set a value. Values on the left are lower and values on the 

right are higher. When you use the left mouse button to drag, the scene updates continuously.
 Drag a slider to the right or left while pressing the Shift key to make finer adjustments.
 Drag a slider to the right or left while pressing the Ctrl key to change the value of all the sliders 

in a color-control group simultaneously.
 Drag with the middle mouse button. When you use the middle mouse button, the scene 

updates only when you release the mouse button instead of refreshing continuously as you 
drag. This is especially useful when setting values on parameters that may take a long time to 
update. Again, press Shift for finer adjustments.

 If you need to specify more precise values than is possible with the sliders, you can enter 
values numerically. 

 Entering Values Outside of Slider Ranges
 Many parameters with sliders let you set values outside of the slider range. For example, the 

range of Local Transform property editor’s Position sliders is between -50 and +50, but objects 
can be much farther from their parent’s origin than that.

 When you set a value outside a slider range, for example by typing it in, the displayed range 
automatically expands to twice the current value. For example, if the default range of a 
parameter is between 0 and 10 and you set the value to 15, the new range is 0 to 30. However, 
the change is not permanent — if you set the parameter to a value within the default range 
and then close and reopen the property editor, the displayed range is back to its default.



 by increments
 Click in the numeric text field 

and press the square bracket 
keys ([) and (]) to increment 
and decrement values as 
follows:

 by increments
 Click in the numeric text field 

and press the arrow keys to 
increment or decrement values 
as follows:

If you have a mouse wheel, click in the numeric text field, then roll the wheel forward to
increment the value or backward to decrement the value.



 You can undo most edits made from the Softimage interface, such as scaling an object or deleting a 
camera. 

 To undo an edit
 Choose the Edit > Undo command or press Ctrl+z. 
 You can continue to undo actions as far back as the system memory can recall. This is limited by the number 

of undo levels that you have specified in your user preferences (see below for setting this).
 Undo does not work on:

 Changes made to shaders
 Changes in viewport manipulations
 Changes to light ray properties

 To redo an edit
 Choose the Edit > Redo command or press Ctrl+y. You can invoke one redo command for each undo action.

 Setting the Number of Undo Levels
 There’s enough space in the system memory to let you undo up to 1000 edits.

 To set the number of undo levels
 Choose File > Preferences to open the Preferences window.
 Click General.
 In the Number of Undo Levels text box, enter the number of edits that can be undone.



 There are four viewports in the view manager at the center of the standard Softimage layout. Each viewport is 
identified by a letter. When you start Softimage, viewport A (top left) shows the Top orthographic view, viewport 
B (top right) shows the Camera perspective view, viewport C (bottom left) shows the Front orthographic view, and 
viewport D (bottom right) shows the Right orthographic view. 

 The current view — that is, the last view you clicked in — is highlighted with a white border. 



 The viewing area of the interface contains four windows, called viewports, where you can view and work on your scene. Each viewport can display 
different types of views. You can display up to four different views in the viewports. 

 Viewports can have different geometry views (Top, Front, Right, and User) and display types (Shade, Wireframe, Texture, Hidden Line, etc.). They can 
also display other tools such as the animation editor, browser, and the explorer. Any viewport can display any type of view.

 A viewport’s menu bar contains a set of controls that allow you to perform various functions such as changing views and display types, setting scene 
visibility, and resizing the viewport.



 The Active Viewport
 Clicking anywhere in a viewport makes it the “active” viewport. This is 

indicated by a thin grey border around the viewport. The active viewport 
is the camera/viewpoint view that is rendered when you use the Render 
toolbar’s Render > Preview > Active Camera command. For more 
information about preview rendering.

 Muting and Soloing Viewports
 When a viewport is muted, it is prevented from displaying its contents. Muting 

a viewport’s neighbors helps speed up its refresh rate. 
 To mute or solo viewports
 To solo (view just one viewport), left-click on its letter. Left-click a second time 

to redisplay all viewports.
 To mute a viewport, middle-click on its letter. Middle-click a second time to 

redisplay the viewport.
 Right-click a viewport’s letter to display a menu with mute and 

solo commands.



 You can display many different 
views docked inside the 
viewports. 

 To display a view in a viewport
 Click the arrow or the name of 

the current view displayed on 
any viewport menu bar to 
open the Views menu.

 Select the desired view from 
the menu. 

 To display the previous view in 
a viewport
 Middle-click the arrow or the 

name of the view on the 
viewport menu bar.



 You can maximize a single viewport so that it 
occupies the full space taken by all four viewports. 
Alternatively, you can maximize viewports 
horizontally or vertically to display two or three 
viewports at a time. Restoring a viewport returns it 
to the previous size.

 To maximize or restore a viewport
 Do one of the following: 

 With the mouse pointer over the corresponding 
viewport, press F12.

 Click the viewport’s Resize icon.
 Right-click the viewport’s Resize icon, then choose 

Maximize or Restore. 

 To maximize or restore a viewport horizontally
 Do one of the following: 

 Middle-click the viewport’s Resize icon.
 Right-click the viewport’s Resize icon, then choose 

Horizontal or Restore. 

 To maximize or restore a viewport vertically
 Do one of the following: 

 Ctrl+middle-click the viewport’s Resize icon.
 Right-click the viewport’s Resize icon, then choose 

Vertical or Restore. 



 You can change the relative sizes of the viewports, as well as reset them to their original 
sizes. 

 To resize viewports
 To resize horizontally, click and drag the vertical splitter bar that separates two viewports. 
 To resize vertically, click and drag the horizontal splitter bar that separates two viewports. 
 To resize freely, click and drag the intersection of the splitter bars that separates all four viewports. 

 To reset the viewport sizes
 To reset the size horizontally, middle-click the vertical splitter bar that separates two viewports. 
 To reset the size vertically, middle-click the horizontal splitter bar that separates two viewports. 
 To reset the size both horizontally and vertically, middle-click the intersection of the splitter bars that 

separates all four viewports. 

 Returning to the Default Viewports
You can return to the original state of the viewports by doing one of the following:
 Right-click the viewport’s Resize icon, then choose Reset Size. All four viewports are restored and 

their sizes are reset.
 Right-click the viewport’s Resize icon, then choose Reset All. All four viewports are restored, their 

sizes are reset, and the default views are displayed.



 Viewpoints show you the geometry of 
objects in a scene. They can be viewed in 
the render region, but they cannot be 
rendered like camera views. 

 You can also choose different display types 
to change the visual appearance of the 
objects seen in viewpoints.

 Top, Front, and Right Views
 The Top, Front, and Right views are parallel 

projection views, called such because the object’s 
projection lines do not converge in these views. 
Because of this, the distance between an object 
and the camera has no influence on the scale of 
the object. If one object is close to the camera, 
and an identical object is farther away, both 
appear to be the same size.

 The Top, Front, and Right views are orthographic, 
which orients the camera so it is perpendicular 
(orthogonal) to specific planes:
▪ The Top view faces the XZ plane.
▪ The Front view faces the XY plane.
▪ The Right view faces the YZ plane.



 The explorer (shortcut 8) displays the 
contents of your scene in a hierarchical 
structure called a tree. This tree can show 
objects as well as their properties as a list of 
nodes that expand from the top root.

 You normally use the explorer as an adjunct 
while working in Softimage, for example, to 
find or select elements. Using the explorer, 
you can:
 Display and navigate among various elements.
 Select scene elements.
 Set the scope to determine the range of 

information shown.
 Set filters to determine the types of 

information shown.
 Find objects by name.
 Sort and reorder elements.
 Rename scene elements.
 Create parent/child relationships between 

objects by dragging and dropping.
 Add objects to groups, layers, and partitions 

by dragging and dropping.
 Duplicate elements by Ctrl+dragging.



 The explorer displays 
elements in a tree-like 
hierarchy of nodes. 
 You can pan the view by 

dragging up and down in an 
empty area within the 
explorer.

 If your mouse has a wheel, 
you can also use it to scroll 
up and down in an explorer 
window. Simply make sure 
the explorer has focus (click 
anywhere in the explorer) 
before using the wheel.



 The spreadsheet view displays scene information about elements and their parameters in a grid. 
This information is filtered and organized by queries that you create to show specific aspects of 
your scene in combination with sorting operations you can perform based on object data. You can 
then perform operations on many elements or parameters at once.



 The schematic view presents the scene in a hierarchical structure so that you can analyze the way a 
scene is constructed. It includes graphical links that show the relationships between objects, as 
well as material and texture nodes to indicate how each object is defined.



 The Softimage file browser is a type of window specifically used to:
 Search (browse) through scene databases, project directories, preset libraries, and other repositories whose files are required to 

build a project.
 Import scene files from databases as well as load scene and project files. 
 Perform file management tasks such as moving, copying, renaming, and deleting files.


	Interface and Tools��
	Basic Interactions with Softimage
	The First Time You Start Softimage
	The Softimage Interface
	Main Menu Bar�
	Toolbars	
	Icons
	Lower Interface Controls
	Main Command Panel
	Using the Menus
	Using the Menus
	Using Access and Shortcut Keys
	Using Shortcut Keys to Activate Tools
	Modifying Properties in Property Editors
	Property Editor
	Property Editor
	Property Editor
	Displaying Property Editors
	Setting Values for Parameters
	Enter Values Using Sliders
	To enter information
	Undoing and Redoing Edits
	Working with Views Docked in the Viewports
	Viewports
	Viewports	
	Displaying Views in Viewports
	Maximizing and Restoring Viewports
	Resizing Viewports
	Viewpoints
	The Explorer
	Explorer: Element Tree
	The Spreadsheet
	The Schematic View
	The Browser

